手机配资股票开户过程-在线股票配资网咨询|股票配资真实网站
栏目分类
热点资讯
股票配资真实网站

你的位置:手机配资股票开户过程-在线股票配资网咨询|股票配资真实网站 > 股票配资真实网站 > 通达信牛熊争锋主图指标公式(附源码破译和源码)

通达信牛熊争锋主图指标公式(附源码破译和源码)

发布日期:2024-03-14 19:07    点击次数:169

编程思路破译

当满足条件1时,在横轴0纵轴0位置书写文字,COLORFF60FF

当满足条件1时,在横轴0.05纵轴0位置书写文字,COLORFF60FF

当满足条件1时,在横轴0.1纵轴0位置书写文字,COLORFF60FF

当满足条件1时,在横轴0纵轴0.08位置书写文字,COLOR6F59FF

当满足条件1时,在横轴0.05纵轴0.08位置书写文字,COLOR6F59FF

输出股东数:引用242号ID的序列数据,NODRAW

输出C90:获利盘为90%的成本分布,DOTLINE,画红色

X_1赋值:如果总量>0.01,返回0.01*总金额/总量,否则返回昨收盘价

X_2赋值:最高价< 0.01 OR 最低价< 0.01

X_3赋值:如果X_2,返回1,否则返回X_1<最高价+0.01ANDX_1>最低价-0.01

输出CYC243:如果X_3,返回0.01*成交额(元)的243日指数移动平均/成交量(手)的243日指数移动平均,否则返回(最高价+最低价+收盘价)/3的243日指数移动平均,画白色,线宽为3

当满足条件收盘价上穿CYC243时,在最高价*1.09位置画42号图标

K线

X_4赋值:如果收盘价/1日前的收盘价>=1.0992,返回1,否则返回0

当满足条件X_4时,在开盘价和收盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,画红色

当满足条件X_4时,在开盘价和收盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,画黄色

程序源码

DRAWTEXT_FIX(1,0,0,0,4658),COLORFF60FF;

DRAWTEXT_FIX(1,0.05,0,0,HYBLOCK),COLORFF60FF;

DRAWTEXT_FIX(1,0.1,0,0,FGBLOCK),COLORFF60FF;

DRAWTEXT_FIX(1,0,0.08,0,4659),COLOR6F59FF;

DRAWTEXT_FIX(1,0.05,0.08,0,DYBLOCK),COLOR6F59FF;

股东数:FINVALUE(242),NODRAW;

C90:COST(90),DOTLINE,COLORRED;

X_1:=IF(DYNAINFO(8)>0.01,0.01*DYNAINFO(10)/DYNAINFO(8),DYNAINFO(3));

X_2:=DYNAINFO(5)< 0.01 OR DYNAINFO(6)< 0.01;

X_3:=IF(X_2,1,X_1< DYNAINFO(5)+0.01 AND X_1>DYNAINFO(6)-0.01);

CYC243:IF(X_3,0.01*EMA(AMOUNT,243)/EMA(VOL,243),EMA((HIGH+LOW+CLOSE)/3,243)),COLORWHITE,LINETHICK3;

DRAWICON(CROSS(CLOSE,CYC243),HIGH*1.09,42);

DRAWKLINE(HIGH,OPEN,LOW,CLOSE);

X_4:=IF(CLOSE/REF(CLOSE,1)>=1.0992,1,0);

STICKLINE(X_4,OPEN,CLOSE,2,0),COLORRED;

STICKLINE(X_4,OPEN,CLOSE,0.5,0),COLORYELLOW;

该公式包含未来函数:COST未发现:CAPITAL...该公式包含未来函数:DYNAINFO

注:

       馆内各种公式为学习编程而保存,实战使用前一定要看其中是否有未来函数并自己亲自测试成功率,决不能依据公式名称的描述和形容去投资,据此入市造成投资损失由投资者自己承担。

本站仅提供存储服务,所有内容均由用户发布,如发现有害或侵权内容,请点击举报。

友情链接: